We are seeing systems beginning to come back online as the broader Google Cloud outage is being resolved. Our team is closely monitoring system performance to ensure full stability and functionality. We will continue to provide updates as we confirm recovery across all services.
Posted Jun 12, 2025 - 11:48 PDT
Update
We have identified key Snackpass features that are negatively affected by the Google Cloud Outage: - Restaurant dashboard: Login blocked - Online ordering: Order placement blocked due to phone number verification failure - Rewards on kiosk/register: Cannot be redeemed - Snackpass app: Login blocked - Deliverect delivery integration: Deliverect is also experiencing failures due to their reliance on Google Services
Posted Jun 12, 2025 - 11:41 PDT
Identified
We are aware of issues logging into Restaurant Dashboard, Online Ordering, and the Snackpass app. The issue is caused by an ongoing Google Cloud outage. Google Cloud Servers act like an electricity grid for our POS and many third party tools worldwide. We are working to get more information from Google including issue status resolution steps. We will update you here as soon as we have an expected resolution time.
Posted Jun 12, 2025 - 11:37 PDT
This incident affected: Order Processing (Kiosk, Online Ordering, Snackpass Mobile App, Stripe Payment Processing), Order Management (Printers, SnackTV, OrderHub / KDS), Back of House (Restaurant Dashboard, Time & Attendance, Payouts), Third Party Integrations (Deliverect - Delivery Integration, Chowly - POS Integration, Checkmate - POS integration), and Product Support (Phone Call, Live Chat, Email).