Outage with Our Support Service Provider - Severe Delays in Service

Incident Report for Snackpass System

Resolved

Intercom has resolved their outage. All support channels are now fully operational. Thank you for your patience and understanding.
Posted May 29, 2024 - 09:40 PDT

Investigating

Our product support service provider, Intercom, is currently experiencing a major outage. As a result, we are unable to handle inbound communications via phone, live chat, or email effectively.

We are closely monitoring updates from Intercom and will provide further information as soon as possible. We sincerely apologize for any inconvenience this may cause.

Thank you for your understanding.
Posted May 29, 2024 - 09:15 PDT
This incident affected: Product Support (Phone Call, Live Chat, Email).